How-to

How to get a better browser

So you’ve seen a banner at the top of Easy Crypto saying that your browser isn’t supported, and you can’t place an order?

We’re sorry about that, but we need to make sure you’re using a secure, up-to-date browser before you buy through the site.

It’s an easy fix – just choose one of the options below to get a better browser:

Chrome

Get it on iOS or Google Play

Download the desktop version

You will need version 62 or higher.

Firefox

Get it on iOS or Google Play

Download the desktop version

You will need version 57 or higher.

Safari

If you’re on an iPhone or iPad and you get an unsupported browser message, it means you need to upgrade your current version of Safari. Go to the App Store and find Safari under “updates” to upgrade.

We require Safari 10.3 or higher.

Related Articles

  • How to create a secure IOTA seed on Windows

    If you’re using our Portfolio, we handle this all for you. But if you to create your own IOTA wallet, you’ll need to make a ‘seed’. The easiest way to create...

  • How to verify your balance

    For most cryptocurrencies, it’s very easy to check the amount that is sitting in your wallet. However, in order to keep your wallet secure, you must make sure that when...